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Version 17.13 Release Notes

This document provides important information regarding new features and changes in your Sage
Estimating 17.13 software. Read these release notes carefully before installing Sage
Estimating 17.13.
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Installation Notes

System Requirements
For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 86064, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=86064.

Note:While Sage Estimating continues to support 32-bit Microsoft SQL Server, the installation
package includes only the 64-bit Microsoft SQL Server Express application.

Installing Sage Estimating
Refer to the Installation and Administration Guide for complete instructions on installing the software,
and migrating or upgrading your data.

Before Upgrading

Important!
If you are upgrading to version 17.13 and you are using third-party software that integrates with
Sage Estimating, check with the third-party software vendor to ensure that their software is
compatible with version 17.13 before you upgrade.

Installation Notes
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New Features and Enhancements

Sage Estimating version 17.13 includes:

l Expanded Copy Assembly functionality

l New Advanced Reporting options

l Revised Standard Database window

l Improved database security

l Miscellaneous improvements

The following sections describe these changes in more detail.

Expanded Copy Assembly functionality
Version 17.12 introduced the ability to copy assemblies between estimates, saving estimators time
and effort when generating takeoffs, while retaining critical pass information that makes Smart
Assemblies so useful.

With version 17.13, we have improved the Copy Assembly functionality within an estimate. You no
longer need to copy an assembly within the Assembly sequence first, and then move the items to a
newWBS group separately. Now, you can move or copy selected items and/or assemblies to new or
existing locations, WBS codes, or alternates in a single operation.

As with previous versions, the Copy operation is available after selecting a series of spreadsheet
items and collapsed overlines.

Tip: The Move/Copy window is now accessible from the spreadsheet's row header for most
sequences.

New Features and Enhancements
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Now, you can confirm the count of complete assemblies and items before proceeding.

Once processed complete assemblies appear intact, with all review assembly and pass details
available.

If the items you select represent only part of an assembly, they are copied as unassigned items, with
no associated assembly header or pass information.

For more information about copying assemblies within an estimate, see the Estimating help.

New Features and Enhancements
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NewAdvanced Reporting options
We've heard your requests for more flexibility in visualizing your estimates.

If you are an advanced user and you have a license for the Advanced Reporting module, you can
take advantage of the following new report types when creating custom reports:

l SQL Server Reporting Services reports

l External reports

SQL Server Reporting Services (SSRS), part of the Microsoft SQL Server services suite, is a market-
leading reporting technology. Using the Report Designer that comes with SSRS, you can quickly
build and deploy sophisticated tables, charts and graphs. As with the existing Crystal report type, you
can view these reports easily from Sage Estimating, and then export them to a PDF or Microsoft
Excel format.

If you need even more versatility, you can use the External report type to run an independent report
processor. The External report type liberates a creative report developer with programming
experience to design reports to your exact specifications.

For more information about creating reports using the new report types, talk to your business
partner.

Revised Standard Database window
In version 17.13, we have modernized the Standard Database settings window, making it consistent
with the Estimate Information window.

New Advanced Reporting options
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A new Notes field enables database developers to document important information about the
database, such as pricing sources, means and methods strategies, price update dates, and so on.

To enter a note, you click the new [Notes] button , which opens a separate Notes window.

A newGeneral section contains additional database properties, including information about who
created the database and when it was released.

Note: You require a new Edit standard database settings permission, as well as Edit Standard
Database permission, to view the [Edit] button, which you must click before you can edit database
settings or add a note for the database in this window.

For more information about standard database settings, as well as the new feature permission, see
the Estimating Management Console help.

Improved database security
Sage is committed to protecting proprietary and sensitive data for both the developer who creates a
database and the estimator who is using it. In version 17.13, we have strengthened security for
standard cost databases, enabling database vendors and Sage consultants to control how the
database is shared.

New Features and Enhancements
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As a database administrator, you can restrict access to a database, making it impossible for
unauthorized users to open it in Sage Estimating. Once you publish the database, you can generate
an activation code for a specific registration name, authorizing the registered company to use the
database.

Tip: You can also use this feature to control the distribution of databases you develop
independently in your organization with partners and subsidiaries.

The rights properties are updated when you migrate or upgrade databases created with earlier
versions of Estimating. If your database is protected exclusively for you, your organization is shown
as the publisher. If you purchased the database (from Sage, for example), the vendor is the
publisher.

For more information about restricting access to proprietary databases, see the Estimating help.

Improved database security
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Miscellaneous improvements
Version 17.13 includes the following additional improvements:

l You can now view and edit the following estimate tables even when the standard cost
database is closed:

l Phase

l Crews

l Rate Tables

l Cost Indexes

l Bills of Material

l WBS Settings and Values

l You can use the Item Sort icon on the Data ribbon to create additional item sorting options.
This functionality was previously available from the Standard Database Settings window.

l Many editing functions are now available for both estimates and databases from the Data
ribbon. (For example, you can use the WBS icon to edit WBS codes and values for estimates
as well as for databases. Similarly, you can use the Bill of Materials icon to edit bills of material
for estimates or for databases.)

l You can assign a new Edit Standard Database Settings feature to a role in the Estimating
Management Console. Users who do not have this permission cannot edit the database
settings.

New Features and Enhancements
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Fixes Since the Previous Version

Version 17.13 includes the following fixes:

l When you open the Standard Database Settings window from the File menu in Estimating, the
window correctly displays the settings for the standard database that is open in Estimating.

l Reprice Crews now updates only selected categories when you reprice an estimate.

l When you rename a crew resource using a numeric value, the resource name is now
formatted properly.

l The spreadsheet report prints notes correctly when you select Prefill from layout on the
Font/layout tab in the Spreadsheet Report options window.

l The Spreadsheet Layouts window is not hidden while it waits for a response from Estimating,
so that it no longer appears to have stopped working when you have a large number of
layouts.

l Estimating no longer stops working when an estimate scan encounters lump sum amounts.

l In the Estimating Management Console, when creating a new standard database, you no
longer receive a "read catalog" error message when you try to Browse to the branch where
you want to locate the new database.

l In the Estimating Management Console, you no longer receive an exception error if you click
EMC > Tools when you have an invalid Estimates database.

l In the Estimating Management Console, when setting up a Text type job cost interface for a
standard database, you no longer receive a "Job Cost Interface Failure" error when you click
[Setup] in the Job Cost Information section.

Fixes Since the Previous Version
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Known Issues

Problem withmigrated standard databases and estimates
that used a job cost interface
If you migrated a standard database or an estimate that was integrated with job cost in Estimating
(Pervasive), you need to perform a few additional steps to reintegrate the standard database or
estimate in Estimating (SQL).

Important! Until you perform the following steps, you will receive a Job Cost Interface Failure error
when you try to edit job cost settings for a standard database or an estimate that was integrated
with job cost in Estimating (Pervasive). Also, you will not be able to use the standard database with
new interfaced estimates in Estimating (SQL).

Before you start

You need to be assigned to a role with Run Management Console, Edit Standard Databases, Edit
Standard Database Settings permissions, and have Edit access to the estimates to use the job cost
system setup.

For each migrated standard database that used a job cost interface in Estimating
(Pervasive):

1. In the Estimating Management Console, click Standard DB on the ribbon.

2. In the Standard Database Catalog, select the migrated standard database.

3. In the details pane to the right, click [Edit]

4. In the Job Cost Information section:

a. For the Job cost system name, select either None or Text.

b. Click [Save].

c. For the Job cost system name, select Sage 300 Construction.

Known Issues
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d. Click [Setup], and enter the job cost settings required to reintegrate the database with
Sage 300 Construction.

5. Click [Save].

6. Repeat steps 2 through 5 for each migrated estimate that used the job cost interface in
Estimating (Pervasive).

Note: To edit estimates, you must first click Estimates on the ribbon, and then (in step 2) you
select the estimate from the Estimate Catalog.

You cannot install Microsoft SQL Server from a folder that
has a long path
If you start the Sage Estimating installer from a path that is longer than 100 characters, you will
receive the error “Exit Code 9 The storage control block address is invalid” in the log file when you
install the software.

To avoid this error, move the Install folder higher up in the tree (closer to the root folder).

Checking in a Standard Database from the Database Editor
Closes the Database for Concurrent Users
You can work on a Standard database in the Estimating Database Editor while other users perform
takeoff using the same database in the Sage Estimating program.

When you try to check in the Standard database while other users have the database open, you
receive a warning that if you continue to check the file in, there may be unpredictable results for the
concurrent users.

If you continue to check the file in despite the warning, the Estimating program stops working for the
other users. However, the data is not corrupted and the Estimating program is not damaged.

You cannot install Microsoft SQL Server from a folder that has a long path
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Further Assistance

Sage provides you with the following resources for obtaining assistance with Sage Estimating.

Online Help
The Sage Estimating software includes online Help, which provides answers to your questions about
procedures as well as items in the windows.

To view Help in the Sage Estimating software, click the Help button or icon, or press [F1] to display
the Help topic for that window.

For more information about using the online Help, see the Sage Estimating Help.

Training
Sage University offers online and classroom training sessions to help you get the most out of your
Sage Estimating software. To access Sage University, visitwww.sageu.com.

You can also get access to Sage University from the File menu by selecting Help > Sage University.

Technical Assistance
When you need assistance, refer to the Knowledgebase article How do I get technical support for
Sage Estimating? to determine which service works best for you.

Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click on
the File menu button and select Help > Submit Product Idea.

Further Assistance
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